POJ 1742 Coins

Coins
Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 25127Accepted: 8498

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source


虽然和HD一样的题,但是不能用背包算了。。。。


#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int N,V;
int a[111],c[111];
int dp[111111];
int sum[111111];//到当前位置硬币使用了几个

int main()
{
while(scanf("%d%d",&N,&V))
{
    int ans=0;
    if(N==0&&V==0) break;

    for(int i=0;i<N;i++)
        scanf("%d",&a);
    for(int i=0;i<N;i++)
        scanf("%d",&c);

    memset(dp,0,sizeof(dp));
    dp[0]=1;

    for(int i=0;i<N;i++)
    {
        memset(sum,0,sizeof(sum));
        for(int j=a;j<=V;j++)
        {
            if(dp[j]==0&&dp[j-a]==1&&sum[j-a]<c)
            {
                dp[j]=1;
                sum[j]=sum[j-a]+1;
                ans++;
            }
        }
    }

    printf("%d\n",ans);

}

    return 0;
}
 
原文地址:https://www.cnblogs.com/CKboss/p/3351028.html