集训第四周(高效算法设计)F题 (二分+贪心)

Description

Download as PDF
 

A set of n<tex2html_verbatim_mark> 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l<tex2html_verbatim_mark> and each item i<tex2html_verbatim_mark> has length li$ le$l<tex2html_verbatim_mark> . We look for a minimal number of bins q<tex2html_verbatim_mark> such that

  • each bin contains at most 2 items,
  • each item is packed in one of the q<tex2html_verbatim_mark> bins,
  • the sum of the lengths of the items packed in a bin does not exceed l<tex2html_verbatim_mark> .

You are requested, given the integer values n<tex2html_verbatim_mark> , l<tex2html_verbatim_mark> , l1<tex2html_verbatim_mark> , ..., ln<tex2html_verbatim_mark> , to compute the optimal number of bins q<tex2html_verbatim_mark> .

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.


The first line of the input file contains the number of items n<tex2html_verbatim_mark>(1$ le$n$ le$105)<tex2html_verbatim_mark> . The second line contains one integer that corresponds to the bin length l$ le$10000<tex2html_verbatim_mark> . We then have n<tex2html_verbatim_mark> lines containing one integer value that represents the length of the items.

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


For each input file, your program has to write the minimal number of bins required to pack all items.

Sample Input 

1

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output 

6


Note: The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.

epsfbox{p3503.eps}
这道首先使用使用贪心的思路,先模拟贪心过程:给出一个桶,那么这个桶能装两个就两个,不行就算了
具体实现:把数组从小到大排序,然后使用两个变,一个在左,一个在右,首先以右边为据,在左边尽量找一个和它放在一个桶里,如果成功就有i++和j--,直到i和j相遇,跳出循环,统计这时已拿出的桶的数量,即为答案
 
#include"iostream"
#include"algorithm"
using namespace std;

const int maxn=100000+10;

int n,l;
int a[maxn];

void Init()
{
    cin>>n>>l;
    for(int i=0;i<n;i++) cin>>a[i];
}

void Work()
{
 sort(a,a+n);
 int j=0,ans=0;
 for(int i=n-1;i>=0;i--)
{
    if(i<j) break;
    ans++;
    while(a[i]+a[j]<=l&&i>j)
    {
        j++;
        break;
    }
}
cout<<ans<<endl;
}

int main()
{
    int T,t;
    cin>>T;
    t=T;
    while(T--)
    {
     if(t!=T+1) cout<<endl;
     Init();
     Work();
    }
    return 0;
}

 

原文地址:https://www.cnblogs.com/zsyacm666666/p/4704932.html