hdu3438 Buy and Resell(优先队列+贪心)

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2441    Accepted Submission(s): 924


Problem Description
The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.
 
Input
There are multiple test cases. The first line of input contains a positive integer T (T250), indicating the number of test cases. For each test case:
The first line has an integer n. (1n105)
The second line has n integers a1,a2,,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1ai109)
It is guaranteed that the sum of all n is no more than 5×105.
 
Output
For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.
 
Sample Input
3 4 1 2 10 9 5 9 5 9 10 5 2 2 1
 
Sample Output
16 4 5 2 0 0
Hint
In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0
 
Source
题意:你可以从1-n中的物品中,选择买入一件物品,或者卖出一件物品
题解:优先队列+贪心
你可以在队列中每次push两次,但堆顶的元素小于现在的元素时,你就做一次累加;
当时买卖次数只需加两次,就是最小值买入和最大值卖出;第一个push就相当于做
一次反悔操作,而第二个push是真正买入,就是把他当作下一个真正买入的最低
物品。
代码:
#include<iostream>
#include<vector>
#include<queue>
#include<stdio.h>
#include<assert.h>
#include<functional>
using namespace std;
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
#define SZ(x) ((int)(x).size())
typedef vector<int> VI;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<ll,ll> pll;
const ll mod=1000000007;
ll powmod(ll a,ll b) {ll res=1;a%=mod; assert(b>=0); for(;b;b>>=1){if(b&1)res=res*a%mod;a=a*a%mod;}return res;}
ll gcd(ll a,ll b) { return b?gcd(b,a%b):a;}
// head
int T;
int n;
ll val;
int main()
{
    cin>>T;
    priority_queue<pll, vector<pll>, greater<pll> > que;
    while(T--)
    {
        while(que.size()) que.pop();
        cin>>n;
        ll ans=0;
        ll num=0;
        for(int i=0;i<n;i++)
        {
            cin>>val;
            if(que.size()&&que.top().fi<val)
            {
                num++;
                pll tmp=que.top(); que.pop();
                ans+=val-tmp.fi;
                if(tmp.se==1)num--;
                else num++;
                que.push(mp(val,1));
                que.push(mp(val,2));
            }
            else
             que.push(mp(val,3));
        }
        cout<<ans<<" "<<num<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/zhgyki/p/9630609.html