HDOJ 3359 Kind of a Blur


用高斯消元对高斯模糊的图像还原....


Kind of a Blur

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1321    Accepted Submission(s): 383


Problem Description
Image blurring occurs when the object being captured is out of the camera's focus. The top two figures on the right are an example of an image and its blurred version. Restoring the original image given only the blurred version is one of the most interesting topics in image processing. This process is called deblurring, which will be your task for this problem.
In this problem, all images are in grey-scale (no colours). Images are represented as a 2 dimensional matrix of real numbers, where each cell corresponds to the brightness of the corresponding pixel. Although not mathematically accurate, one way to describe a blurred image is through averaging all the pixels that are within (less than or equal to) a certain Manhattan distance?

from each pixel (including the pixel itself ). Here's an example of how to calculate the blurring of a 3x3 image with a blurring distance of 1:


Given the blurred version of an image, we are interested in reconstructing the original version assuming that the image was blurred as explained above.


 

Input
Input consists of several test cases. Each case is specified on H + 1 lines. The first line specifies three non negative integers specifying the width W, the height H of the blurred image and the blurring distance D respectively where (1<= W,H <= 10) and (D <= min(W/2,H/2)). The remaining H lines specify the gray-level of each pixel in the blurred image. Each line specifies W non-negative real numbers given up to the 2nd decimal place. The value of all the given real numbers will be less than 100.
Zero or more lines (made entirely of white spaces) may appear between cases. The last line of the input file consists of three zeros.
 

Output
For each test case, print a W * H matrix of real numbers specifying the deblurred version of the image. Each element in the matrix should be approximated to 2 decimal places and right justified in a field of width 8. Separate the output of each two consecutive test cases by an empty line. Do not print an empty line after the last test case. It is guaranteed that there is exactly one unique solution for every test case.
 

Sample Input
2 2 1 1 1 1 1 3 3 1 19 14 20 12 15 18 13 14 16 4 4 2 14 15 14 15 14 15 14 15 14 15 14 15 14 15 14 15 0 0 0
 

Sample Output
1.00 1.00 1.00 1.00 2.00 30.00 17.00 25.00 7.00 13.00 14.00 0.00 35.00 1.00 27.00 2.00 28.00 21.00 12.00 17.00 8.00 21.00 12.00 17.00 8.00 1.00 27.00 2.00 28.00
Hint
The Manhattan Distance (sometimes called the Taxicab distance) between two points is the sum of the (absolute) difference of their coordinates. The grid on the lower right illustrates the Manhattan distances from the grayed cell.
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const double eps=1e-8;
const int maxn=130;

double data[maxn/10][maxn/10],a[maxn][maxn],x[maxn];
int n,m,d;

int equ,val;

void Gauss()
{
    int k,col,mar;
    for(k=0,col=0;k<equ&&col<val;k++,col++)
    {
        mar=k;
        for(int i=k+1;i<equ;i++)
        {
            if(fabs(a[i][col])>fabs(a[mar][col]))
                mar=i;
        }
        if(fabs(a[mar][col])<eps) return ;
        if(k!=mar)
        {
            for(int i=col;i<val;i++)
                swap(a[k][i],a[mar][i]);
            swap(x[k],x[mar]);
        }
        x[k]/=a[k][col];
        for(int i=col+1;i<val;i++)
            a[k][i]/=a[k][col];
        a[k][col]=1.;
        for(int i=0;i<equ;i++)
        {
            if(i==k) continue;
            x[i]-=x[k]*a[i][col];
            for(int j=col+1;j<val;j++)
                a[i][j]-=a[k][j]*a[i][col];
            a[i][col]=0;
        }
    }
}

int main()
{
    bool fst=false;
    while(scanf("%d%d%d",&m,&n,&d)!=EOF)
    {
        if(n==0&&m==0) break;
        if(fst) putchar(10);
        else fst=true;
        memset(a,0,sizeof(a));
        memset(x,0,sizeof(x));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%lf",&data[i][j]);
                int cnt=0;
                int t1=i*m+j,t2=0;
                for(int ii=0;ii<n;ii++)
                {
                    for(int jj=0;jj<m;jj++)
                    {
                        if(abs(i-ii)+abs(j-jj)<=d)
                        {
                            t2=ii*m+jj;
                            a[t2][t1]=1.;
                            cnt++;
                        }
                    }
                }
                x[t1]=data[i][j]*cnt;
            }
        }
        equ=val=n*m;
        Gauss();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                printf("%8.2lf",x[i*m+j]);
            }
            putchar(10);
        }
    }
    return 0;
}




原文地址:https://www.cnblogs.com/zhchoutai/p/6792018.html