1094 The Largest Generation (25 分)dfs或bfs求图的最大宽度

1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4
思路:
bfs和dfs都可以,主要是求图的最大宽度,与其对应的层数,dfs更加简洁一些。
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
using namespace std;
vector<vector<int>> pt;
vector<int> curLevel;
int generation[102];
int visited[101];

void bfs()
{
    queue<int> ids;
    ids.push(1);//把根的索引入队
    visited[1]=1;
    curLevel[1]=1;
    generation[1]=1;
    while(!ids.empty())
    {
        int temp=ids.front();
        ids.pop();
        for(auto num:pt[temp])
        {
            if(visited[num]==0)
            {
                ids.push(num);
                visited[num]=1;
                curLevel[num]=curLevel[temp]+1;
                generation[curLevel[num]]++;//统计当前层的人数
                //gr.push_back(gr[temp-1]+1);
            }
        }
    }
}
//int book[105];

void dfs(int level,int cur)
{
    generation[level]++;
    for(auto num:pt[cur])
    {
        if(visited[num]==0)
        {
            visited[num]=1;
            dfs(level+1,num,n);
        }
    }
}


int main()
{
    int n,m;
    cin>>n>>m;
    pt.resize(n+1);
    curLevel.resize(n+3);
    for(int i=0;i<m;i++)
    {
        int id0,k;
        cin>>id0>>k;
        int temp;
        for(int j=0;j<k;j++)
        {
            cin>>temp;
            pt[id0].push_back(temp);
        }

    }
    //bfs();
    dfs(1,1);
    int gen=1,level=1;
    for(int i=1;generation[i]!=0;i++)
    {
        if(generation[i]>gen)
        {
            gen=generation[i];
            level=i;
        }
       // cout<<i<<endl;
    }

    cout<<gen<<" "<<level;
    return 0;
}
 
原文地址:https://www.cnblogs.com/zhanghaijie/p/10305222.html