HDU--1060

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14696    Accepted Submission(s): 5660


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L

description:求解N^N的最左边的数字。

解法:num=N^N,两边取对数可得num=10^(N*log10(N))。当中10的整数次方的最左边总是数字10的整数倍。而决定num最左边的因素为N*log10N的小数部分。由此可解!

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		long long int num;
		cin >> num;
		double num1 = num * log10( double (num));
		long long int num2 = (long long int) num1;
		double num3 = num1 - num2;
		num = (long long int) pow(10,num3);
		cout << num<< endl;
	}
	return 0;
} 

做不出本题数学是硬伤啊!!。。。。
原文地址:https://www.cnblogs.com/tlnshuju/p/7093833.html