PAT A1024 Palindromic Number (25 分)——回文,大整数

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (1010​​) is the initial numer and K (100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
 
#include <stdio.h>
#include <string>
#include <algorithm>
#include <iostream>
using namespace std;
long long tonum(string s) {
    long long res = 0;
    for (int i = 0; i < s.length(); i++) {
        res = res * 10 + s[i] - '0';
    }
    return res;
}
string tos(long long num) {
    string res = "";
    do {
        res += '0' + num % 10;
        num /= 10;
    } while (num != 0);
    reverse(res.begin(), res.end());
    return res;
}
string add(string s1, string s2) {
    reverse(s1.begin(), s1.end());
    reverse(s2.begin(), s2.end());
    string s3="";
    int carry = 0;
    int i = 0;
    for (i; i < s1.length() && i < s2.length(); i++) {
        int tmp1 = s1[i] - '0';
        int tmp2 = s2[i] - '0';
        int tmp = tmp1 + tmp2 + carry;
        s3 += tmp % 10 + '0';
        carry = tmp / 10;
    }
    if (s1.length() > s2.length()) {
        while(i<s1.length()){
            if (carry != 0) {
                int tmp1 = s1[i] - '0';
                tmp1 += carry;
                s3 += tmp1 % 10 + '0';
                carry = tmp1 / 10;
                i++;
            }
            else break;
        }
        if (carry != 0) s3 += '0' + carry;
        else if (i < s1.length()) {
            s3 += s1.substr(i, s1.length() - i);
        }
    }
    else if (s1.length() < s2.length()) {
        while (i < s2.length()) {
            if (carry != 0) {
                int tmp1 = s2[i] - '0';
                tmp1 += carry;
                s3 += tmp1 % 10 + '0';
                carry = tmp1 / 10;
                i++;
            }
            else break;
        }
        if (carry != 0) s3 += '0' + carry;
        else if (i < s2.length()) {
            s3 += s2.substr(i, s2.length() - i);
        }
    }
    else if (s1.length() == s2.length()) {
        if (carry != 0) s3 += '0' + carry;
    }
    reverse(s3.begin(), s3.end());

    return s3;
}
bool pali(string s) {
    string s2, s3;
    s2 = s;
    s3 = s;
    reverse(s2.begin(), s2.end());
    if (s2 == s3)return true;
    else return false;
}
int main() {
    string s;
    int k;
    cin >> s >> k;
    int j = 0;
    string s_2;
    s_2 = s;
    if (!pali(s)) {
        for (j = 1; j <= k; j++) {
            s_2 = s;
            reverse(s_2.begin(), s_2.end());
            s = add(s, s_2);
            if (pali(s))break;
        }
    }
    if (j == k + 1)j--;
    cout << s << endl << j;
    system("pause");
}

注意点:又是回文判断题,注意数字可能会超出long long 范围,所以只能用大数相加即两个字符串相加来做,回文的判断直接用了字符串的反转和==。

ps:发现字符串相加想太多了,一个数和他的反转两个数字一定位数是相等的,不用这么麻烦。而且做大整数加法正确的方式是给短的那个数补0,这样直接最后判断一下进位就好了。

---------------- 坚持每天学习一点点
原文地址:https://www.cnblogs.com/tccbj/p/10395413.html