POJ 3253 Fence Repair(贪心)

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
题意:
 将一块很长的木板分成N块,每次切割木板时,开销为这块木板的长度。求出按照目标要求讲木板切割完最小的开销是多少。
题解:
 这道题的贪心方法为每次切割最短的木板(切割顺序可以是自由的)。(逆向考虑,优先合并长度最小的两个木板,至于为什么是最优解,和哈夫曼编码原理相似)。 
时间复杂度为O(N^2)的解法。
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=2e4+5;
int L[maxn];
void solve(int n)
{
    long long ans=0;
    while(n>1)//直到木板为1块为止
    {
        int mii1=0,mii2=1;
        if(L[mii1]>L[mii2])
            swap(mii1,mii2);
        for(int i=2;i<n;i++)//求出最短的板mii1和次短板mii2
        {
            if(L[i]<L[mii1])
            {
                mii2=mii1;
                mii1=i;
            }
            else if(L[i]<L[mii2])
            {
                mii2=i;
            }
        }
        int t=L[mii1]+L[mii2];//将两块板合并
        ans+=t;
        if(mii1==n-1)
            swap(mii1,mii2);
        L[mii1]=t;
        L[mii2]=L[n-1];
        n--;
    }
    cout<<ans<<endl;
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>L[i];
    solve(n);
    return 0;
}

时间复杂度为O(N*logN),需要用到优先队列。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
    int n;
    cin>>n;
    long long ans=0;
    priority_queue<int,vector<int>,greater<int> >que;
    for(int i=0;i<n;i++)
    {
        int x;
        cin>>x;
        que.push(x);
    }
    while(que.size()>1)
    {
        int mii1=que.top();
        que.pop();
        int mii2=que.top();
        que.pop();
        ans+=mii1+mii2;
        que.push(mii1+mii2);

    }
    cout<<ans<<endl;
}
原文地址:https://www.cnblogs.com/orion7/p/7453854.html