poj 2153 Rank List(数据结构+图的用法)

Rank List
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 7883   Accepted: 2561

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output

1
2


题意理解:
(1)这里每次排名是需要把以前每次的成绩累加起来进行的排名----这点需要注意
(2)放在图里边,方便根据名字查找分数,这里键为名字,value为分数。每次都要把分数累加起来
(3)输入要注意,使用gets时,一定要先把前边的回车换行或是空格用getchar先吃掉
(4)查找排名是直接一次遍历即可判断出排名位置
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <map>
using namespace std;

int main()
{
    int N;//N个学生
    char name[35];//学生名字
    int sco;//李明的成绩
    int rank;//李明的排名
    int M;//M次考试
    int score;//总分数表
    //成绩名单映射表
    map<string,int> stu_sco;
    cin>>N;
    getchar();//注意一定要吃掉回车换行符
    for(int i = 1; i <= N; i++)
    {
        //读取名字
        gets(name);
        //初始化,使得每位同学成绩为0
        stu_sco.insert(make_pair(name,0));
    }
    cin>>M;
    getchar();//注意一定要吃掉回车换行符
    while(M--)
    {
        rank = 1;
        for(int i = 1; i <= N; i++)
        {
            cin>>score;
            getchar();//注意一定要吃掉空格。。。。。
            gets(name);
            map<string,int>::iterator it = stu_sco.find(name);
            it->second += score;
            if(it->first.compare("Li Ming")==0)
            sco = it->second;
        }
        for(map<string,int>::iterator it=stu_sco.begin();it!=stu_sco.end();it++)
        if(it->second>sco)rank++;//有人成绩比他的好,他的排名需要向后一位
        cout<<rank<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/newpanderking/p/2679115.html