poj 3414

Pots
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9734   Accepted: 4099   Special Judge

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

Source

Northeastern Europe 2002, Western Subregion

代码里解释非常清楚,非常easy的一道题目

AC代码:

#include<iostream>
#include<queue>
#include<string>
using namespace std;
struct Node{
    int v1,v2;
    int t;
    string str[1000];
    Node(int V1,int V2,int s):v1(V1),v2(V2),t(s){}
};
queue <Node> qu;
int d[105][105];
int sucess;
int main(){
    int a,b,c;
    cin>>a>>b>>c;
    for(int i=0;i<=a;i++)
        for(int j=0;j<=b;j++)
            d[i][j]=0;
    while(!qu.empty())
        qu.pop();
    qu.push(Node(0,0,0));
    d[0][0]=1;
    sucess=0;
    while(!qu.empty()){
        Node tmp=qu.front(); qu.pop();
        if(tmp.v1==c || tmp.v2==c){
            sucess=1;
            cout<<tmp.t<<endl;
            for(int i=0;i<tmp.t;i++)
                cout<<tmp.str[i]<<endl;
            break;
        }
        Node tp=tmp;
        if(tp.v1<a){       //fill(1)
            tp.v1=a;
            if(!d[tp.v1][tp.v2]){
                tp.str[tp.t++]="FILL(1)";
                qu.push(tp);
                d[tp.v1][tp.v2]=1;
            }
        }

        tp=tmp;
        if(tp.v1&&tp.v2<b){       //pour(1,2)
            if(tp.v1+tp.v2<=b){
                tp.v2+=tp.v1;
                tp.v1=0;
                if(!d[tp.v1][tp.v2]){
                    tp.str[tp.t++]="POUR(1,2)";
                    qu.push(tp);
                    d[tp.v1][tp.v2]=1;
                }
            }
            else{
                tp.v1-=(b-tp.v2);
                tp.v2=b;
                if(!d[tp.v1][tp.v2]){
                    tp.str[tp.t++]="POUR(1,2)";
                    qu.push(tp);
                    d[tp.v1][tp.v2]=1;
                }
            }
        }

        tp=tmp;
        if(tp.v1){    //drop(1);
            tp.v1=0;
            if(!d[tp.v1][tp.v2]){
                tp.str[tp.t++]="DROP(1)";
                qu.push(tp);
                d[tp.v1][tp.v2]=1;
            }
        }

        tp=tmp;
        if(tp.v2<b){       //fill(2)
            tp.v2=b;
            if(!d[tp.v1][tp.v2]){
                tp.str[tp.t++]="FILL(2)";
                qu.push(tp);
                d[tp.v1][tp.v2]=1;
            }
        }

        tp=tmp;
        if(tp.v1<a && tp.v2){       //pour(2,1)
            if(tp.v1+tp.v2<=a){
                tp.v1+=tp.v2;
                tp.v2=0;
                if(!d[tp.v1][tp.v2]){
                    tp.str[tp.t++]="POUR(2,1)";
                    qu.push(tp);
                    d[tp.v1][tp.v2]=1;
                }
            }
            else{
                tp.v2-=(a-tp.v1);
                tp.v1=a;
                if(!d[tp.v1][tp.v2]){
                    tp.str[tp.t++]="POUR(2,1)";
                    qu.push(tp);
                    d[tp.v1][tp.v2]=1;
                }
            }
        }

        tp=tmp;
        if(tp.v2){    //drop(2);
            tp.v2=0;
            if(!d[tp.v1][tp.v2]){
                tp.str[tp.t++]="DROP(2)";
                qu.push(tp);
                d[tp.v1][tp.v2]=1;
            }
        }
    }
    if(!sucess)
        cout<<"impossible"<<endl;
    return 0;
}


原文地址:https://www.cnblogs.com/mengfanrong/p/5059883.html