POJ 2236 Wireless Network

Wireless Network
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 14018   Accepted: 5942

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
  为了找工作,最近一直在POJ上做题,终于突破一百道了,但是基本上都是做的最简单的基础题,不过还是纪念一下。

题目大意:输入两个整数N和d代表计算机的数量和每台计算机的最大通信距离,紧接着输入N行,表示每台计算机的坐标,起初每台计算机都是坏的,后面是循环输入命令,如果输入为O i表示第i台计算机已经修好了,如果为S i j则表示查询第i台和第j台计算机之间是否能够通信。
解题方法:用并查集,将彼此之间能够通信的计算机放入到一个并查集之中,通过查询两台计算机是否位于同一集合来判定两台计算机之间能否通信。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include <cmath>
#include<algorithm>
using namespace std;

struct UFSTree
{
    int rank;
    int parent;
}t[1010];

struct Node
{
    int x;
    int y;
}node[1010];


void MakeSet(int n)
{
    for (int i = 0; i <= n; i++)
    {
        t[i].rank = 0;
        t[i].parent = i;
    }
}

int FindSet(int x)
{
    if (x != t[x].parent)
    {
        return FindSet(t[x].parent);
    }
    else
    {
        return x;
    }
}

void UnionSet(int x, int y)
{
    x = FindSet(x);
    y = FindSet(y);
    if (t[x].rank > t[y].rank)
    {
        t[y].parent = x;
    }
    else
    {
        t[x].parent = y;
        if (t[x].rank == t[y].rank)
        {
            t[y].rank++;
        }
    }
}

double Distance(int x1, int x2)
{
    Node node1 = node[x1];
    Node node2 = node[x2];
    return sqrt((double)(node1.x - node2.x) * (double)(node1.x - node2.x) + (double)(node1.y - node2.y) * (double)(node1.y - node2.y));
}

int main()
{
    int n, x, y, nCount = -1, repaired[1010];
    double dist;
    char ch;
    cin>>n>>dist;
    for (int i = 1; i <= n; i++)
    {
        scanf("%d%d", &node[i].x, &node[i].y);
    }
    MakeSet(n);
    while(scanf(" %c%d", &ch, &x) != EOF)
    {
        if (ch == 'O')
        {
            repaired[++nCount] = x;
            for (int i = 0; i < nCount; i++)
            {
                if (Distance(x, repaired[i]) <= dist * 1.0 && FindSet(x) != FindSet(repaired[i]))
                {
                    UnionSet(x, repaired[i]);
                }
            }
        }
        else
        {
            scanf("%d", &y);
            if (FindSet(x) != FindSet(y))
            {
                cout<<"FAIL"<<endl;
            }
            else
            {
                cout<<"SUCCESS"<<endl;
            }
        }
    }
    return 0;
}
 
原文地址:https://www.cnblogs.com/lzmfywz/p/3244250.html