hdoj_1016Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15175    Accepted Submission(s): 6903


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
6 8
 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2


DFS水题:

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
int path[30];
bool visited[30];
int n;

bool check(int x)
{
	if(x<=1) return false;
	for(int i=2;i<=sqrt(double(x));i++)
	{
		if(x % i == 0) return false;
	}
	return true;
}

void DFS(int x, int y)
{
	path[y] = x;
	if(y==n&&check(1+path[n]))
	{
		for(int i=1;i<n;i++)
			cout<<path[i]<<" ";
		cout<<path[n]<<endl;
	}
	for(int i=1;i<=n;i++)
	{
		if(!visited[i]&&check(x+i))
		{
			visited[i] = true;
			DFS(i,y+1);
			visited[i] = false;
		}
	}
}

int main()
{
	int m = 1;
	while(cin>>n)
	{
		memset(visited,false,sizeof(visited));
		visited[1] = true;
		printf("Case %d:\n",m++);
		DFS(1,1);
		cout<<endl;
	}
	return 0;
}

ZOJ相同题目,TLE。

看来还得剪枝,会宿舍再想想吧



!!!

当N为奇数的时候,无法构成素数环

int main()
{
	int m = 1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(visited,false,sizeof(visited));
		visited[1] = true;
		printf("Case %d:\n",m++);
		if(n%2==1) printf("\n");
		else
		{
			DFS(1,1);
			printf("\n");
		}
	}
	return 0;
}

碉堡了



加几个函数,就能了解深度优先遍历的基本流程了=。=

#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <windows.h>
using namespace std;
int path[30];
bool visited[30];
int n;

bool check(int x)
{
	if(x<=1) return false;
	for(int i=2;i<=sqrt(double(x));i++)
	{
		if(x % i == 0) return false;
	}
	return true;
}

void DFS(int x, int y)
{
	path[y] = x;
	if(y==n&&check(1+path[n]))
	{
		Sleep(1000);
		for(int i=1;i<n;i++)
			printf("%d ",path[i]);
		printf("%d\n",path[n]);
	}
	for(int i=2;i<=n;i++)
	{
		if(!visited[i]&&check(x+i))
		{
			visited[i] = true;
			DFS(i,y+1);
			visited[i] = false;
		}
	}
}

int main()
{
	int m = 1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(visited,false,sizeof(visited));
		visited[1] = true;
		printf("Case %d:\n",m++);
			DFS(1,1);
			printf("\n");
	}
	return 0;
}


原文地址:https://www.cnblogs.com/lgh1992314/p/5835320.html