poj_1157LITTLE SHOP OF FLOWERS

题目:

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15079   Accepted: 6961

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

Input

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

开始没注意全为负数的情况,wa

状态转移方程:

dp[i][j] = num[i][j] + max(dp[i-1][1],dp[i-1][2],...dp[i-1][j-1]);

我们用opt定义以当前I j为结尾的花的排序的最大值,用r*(-50)表示负无穷,初始化时第一行为origin[i][j],后面为r*(-50)

Opt[][]

1

2

3

4

5

1

7

23

-5

-24

16

2

-150

-150

-150

-150

-150

3

-150

-150

-150

-150

-150

从第二行开始,对于第i行第j列,对于i>=j,遍历i-1行前j列,求出当前最大值。

Opt[][]

1

2

3

4

5

1

7

23

-5

-24

16

2

-150

21+7

-4+max(7,23)

10+max(7,23,-24)

23+max(…)

3

-150

-150

-150

-150

-150

I=3:

Opt[][]

1

2

3

4

5

1

7

23

-5

-24

16

2

-150

28

19

33

46

3

-150

-150

-4+max(-150,28)

-20+max()

20+max(-150,28,19,33)


题解:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
	freopen("in.txt","r",stdin);
	int num[105][105];
	int dp[105][105];
	int n, m, i, j;
	cin >> n >> m;
	for(i = 1; i <= n; i++)
	{
		for(j = 1; j <= m; j++)
		{
			cin >> num[i][j];
		}
	}

	for(i = 1; i <= n; i++)
	{
		for(j = 1; j <= m; j++)
		{
			if(i == 1) dp[1][j] = num[1][j];
			else dp[i][j] = -50 * n;
		}
	}

	for(i = 2; i <= n; i++)
	{
		for(j = 1; j <=m; j++)
		{
			if(j >= i)
			{
				for(int k = 1; k < j; k++)
				{
					if(dp[i][j] < dp[i-1][k] + num[i][j])
						dp[i][j] = dp[i-1][k] + num[i][j];
				}
			}
		}
	}
	int ans = -999999;
	for(i = 1; i <= m; i++)
	{
		ans = max(ans, dp[n][i]);
	}
	cout << ans << endl;
}



原文地址:https://www.cnblogs.com/lgh1992314/p/5835251.html