POJ3624 (01背包)

                                                                                       Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15677   Accepted: 7130

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


又领悟一个新的算法,01背包,也是作为动态规划的一个分支。..总结一下01背包的精髓就是通过数组来将背包容纳量单元化,通过嵌套的循环对每个单元格找出每个单元(即当前容量)的最优解法,循环过后即可得到最优解。

#include <iostream>
#include <cstring>
using namespace std;

int max(int x,int y)
{
    if (x>y) return x;
    return y;
}

int main()
{

    int f[13000];
    memset(f,0,sizeof f);
    int n,m;
    int w,d;
    cin>>n>>m;
    int i,j;
    for (i=1;i<=n;i++)
    {
        cin>>w>>d;
        for (j=m;j>=w;j--)
        {
            f[j]=max(f[j],f[j-w]+d);
        }
    }
    cout<<f[m];
}

  



原文地址:https://www.cnblogs.com/kkrisen/p/3039695.html