首字母变大写



Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm
i want to get an accepted
 
Sample Output
I Like Acm
I Want To Get An Accepted
 
 
code:

#include<iostream>
#include<string>
using namespace std;
int main()
{
         int i,len;
        char str[101];
       while(gets(str))
       {
                len=strlen(str);
                for(i=0;i<len;i++)
                       if(str[i]!=' '&&str[i-1]==' ')
                             str[i]=str[i]-32;
                if(str[0]!=' ')
                     str[0]=str[0]-32;
                cout<<str<<endl;
       }
  return 0;
}

 
 
 
 
 
 
 
 
 
 
原文地址:https://www.cnblogs.com/gongpulin/p/3897671.html