poj 3624 (背包入门)

入门题,最近又一次想不起来背包的dp方法,无奈又得找道水题找找感觉...

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15063   Accepted: 6880

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
#define N 13000
int dp[N];

int main()
{
    int n,m;
    memset(dp,0,sizeof(dp));
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    {
        int tmp,w;
        scanf("%d%d",&w,&tmp);
        for(int j=m;j>=w;j--)
        {
            dp[j]=max(dp[j],dp[j-w]+tmp);
        }
    }
    printf("%d\n",dp[m]);
    return 0;
}
原文地址:https://www.cnblogs.com/chenhuan001/p/2973757.html