HDU3336

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: 
s: "abab" 
The prefixes are: "a", "ab", "aba", "abab" 
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6. 
The answer may be very large, so output the answer mod 10007. 

Input

The first line is a single integer T, indicating the number of test cases. 
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters. 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab

Sample Output

6

思路:此题关键还是next数组的使用,代表着第i个前面的字符串前缀与后缀的匹配

#include <iostream>
using namespace std;
#include <string>
string s;
int n,Next[200005];
void getNext()
{
    int len = n;    
    Next[0]=-1;
    int i=0,j=-1;
    while (i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            ++i;
            ++j;
            Next[i]=j;
        }
        else
            j = Next[j];
    }
}
 
int main()
{
    int t;
    cin>>t;
    while (t--)
    {
        cin>>n;
        cin>>s;
        getNext();
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            int j=i;
            while(j)
            {
            sum = (sum+1)%10007;
            j = Next[j];
            }
        }
        cout<<sum<<endl;
    }
return 0;
}
原文地址:https://www.cnblogs.com/aerer/p/9931015.html