PAT 1016 Phone Bills[转载]

1016 Phone Bills (25)(25 分)提问

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00

  • 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

//看见这种这么长的题目,都不想看,又是字符串处理和模拟仿真的题目,啊!

输出每月的电话费。每一个测试用例都是在同一月份。

输入:24小时每小时的长途话费单价(美分/分钟)

人名 时间 上线/下线    说明:如果一个on-line没有off-line匹配,那么就忽略,off-line也是如此,

输出:按字典序的人名,月份 使用时间段及每段花费,总费用。

//代码来自:https://blog.csdn.net/ysq96/article/details/80438014

#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
#include <string>
#include <cstdio>
using namespace std;

struct customer
{
    customer(){
        this->month=0;
        this->dd=0;
        this->hh=0;
        this->mm=0;
    }
    string name;//名字
    int month,dd,hh,mm;//月 天 时 分
    bool status;
};

bool cmp(customer a, customer b){
    int x = a.name.compare(b.name);
    if(x!=0){
        return x<0;//首先按照名字字母排序
    }else if(a.month!=b.month)
    {//再按照月份排序
        return a.month<b.month;
    }else if (a.dd!=b.dd)
    {//再按照号
        return a.dd<b.dd;
    }else if(a.hh!=b.hh){//再按照小时
        return a.hh<b.hh;
    }else
    {//再按照分钟
        return a.mm<b.mm;
    }
}
    int prize[24];
double get_ans(customer a, customer b,int& time){
    int money=0;
    while (a.dd>b.dd||a.hh>b.hh||a.mm>b.mm)
    {
        time++;
        money+=prize[b.hh];
        b.mm++;
        if (b.mm>=60)
        {
            b.mm=0;
            b.hh++;
        }
        if (b.hh>=24)
        {
            b.hh=0;
            b.dd++;
        }
    }
    return money/100.0;
}
int main(){
    for (int i=0;i<24;i++)
    {
        cin>>prize[i];
    }
    int n;
    string name,status;
    int month,dd,hh,mm;
    cin>>n;
    vector<customer> data(n);
    for(int i=0;i<n;i++){
        cin>>name;
        scanf("%d:%d:%d:%d",&month,&dd,&hh,&mm);//可以这样按照格式输入!,那就不用处理字符串了!
        cin>>status;
        data[i].name=name;
        data[i].month=month;
        data[i].dd=dd;
        data[i].hh=hh;
        data[i].mm=mm;
        if(status.compare("on-line")==0){
            data[i].status=true;//开始标记为true;
        }else
        {
            data[i].status=false;
        }
    }
    sort(data.begin(),data.end(),cmp);
    //先读取第一个人
    customer temp;
    temp=data[0];
    int on=-1,off;
    bool flag=false;
    if (temp.status)
    {
        on=0;
    }
    double total=0.0;
    for (int i=1;i<n;i++)
    {

        if (data[i].name.compare(temp.name)==0)//若此数据名字和上一个数据相同
        {
            if (data[i].status)
            {
                on=i;//记录on下标
            }else
            {
                off=i;//记录off下标
            }
            if (off==on+1)//若此数据为off 上一个数据为on,如果没有符合的话,那么就什么也不输出。
            {
                if (!flag)
                {
                    cout<<data[i].name<<" ";
                    printf("%02d\n",data[i].month);//注意这里的输出格式!
                    flag=true;
                }
                int time=0;
                double bills=0.0;
                bills=get_ans(data[i],temp,time);
                total += bills;
                printf("%02d:%02d:%02d %02d:%02d:%02d",temp.dd,temp.hh,temp.mm,data[i].dd,data[i].hh,data[i].mm);
                cout<<" "<<time;
                printf(" $%.2f\n",bills);
            }
        }else{
            if (flag)
            {
                printf("Total amount: $%.2f\n",total);
                flag=false;
                total=0.0;
            }

        }
        temp=data[i];
        if (data[i].status)
        {
            on=i;//记录on下标
        }else
        {
            off=i;//记录off下标
        }
        if (i==n-1)
        {
            if (flag)
            {
                printf("Total amount: $%.2f\n",total);
            }
        }
    }
    return 0;
}

//相当厉害!

//经过测试用例表明,如果有多个on,只有一个off,那么就和最接近off的配对。

如果测试用例如下:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
4
CYLL 01:01:06:01 on-line
CYLL 01:01:16:01 on-line
CYLL 01:01:16:03 off-line
CYLL 01:01:16:05 off-line

那么输出:

CYLL 01
01:16:01 01:16:03 2 $0.40
Total amount: $0.40

也就是说,如果有多个,第一个on和最后一个off就不匹配了。按时间排序之后,如果当前是on,下一个还是on,那么当前的on就会被抛弃。

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9381255.html