POJ 1050 To the Max

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 35476   Accepted: 18625

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.  As an example, the maximal sub-rectangle of the array: 
0 -2 -7 0  9 2 -6 2  -4 1 -4 1  -1 8 0 -2  is in the lower left corner: 
9 2  -4 1  -1 8  and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
代码:
// 最大连续和扩展
// 最近DP D到吐血= = 对于新手来说好难想到状态 
// 还是好好修炼吧= = 
#include<cstdio>
#include<cstring>
using namespace std ;
#define M 110
int a[M][M] , d[M] ;
int n ;
int Sum()
{
	int max = -3724 , i ;
	int mm = 0 ;
	for( i = 1; i <= n ;i++)
	{
		mm += d[i] ;
		if( mm > max ) max = mm ;
		if( mm < 0 ) mm = 0;
	}
	return max ;
}
int dfs()
{
	int i , j , ans = -1213  , cmp ;
	for( i = 1; i <= n ;i++)
	{
		memset( d , 0 , sizeof(d) ) ;
		for( j = i ; j <= n ;j++)// 枚举行的所以情况
		{
			for( int v = 1; v <= n ; v++)
				d[v] += a[j][v] ;
			cmp = Sum() ; // 列用 最大连续和处理
			//printf( "%d\n" , cmp ) ;
			if( ans < cmp  ) ans = cmp ; 
		}
	}
	return ans ;
}
int main()
{
	int i , j  ;
	while( scanf( "%d" , &n) != EOF )
	{
		for( i = 1; i <= n ;i++)
			for( j  = 1 ;j <= n ;j++)
				scanf( "%d" , &a[i][j] ) ;
		printf( "%d\n" , dfs( ) ) ;
	}
}

  

原文地址:https://www.cnblogs.com/20120125llcai/p/3067923.html