Bad Hair Day

Feel Good
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 14435   Accepted: 3996
Case Time Limit: 1000MS   Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

Source

【解析】
题目大意:有一群奶牛,都有身高。求每头奶牛看到多少头奶牛的脑袋,并加起来。
做法:我们可以不求每头奶牛可以看见多少头奶牛,我们可以计算每头奶牛被多少头牛看见。
我们需要维护一个单调栈。当新加入的牛的身高大于栈顶元素时,弹出栈顶元素,直至栈顶
元素大于当前牛的身高,相当于维护一个递减序列,弹完之后,栈中元素的个数就是看见这头牛
的牛的数量。
注意:开long long 
【code】
//bad
#include<cstdio>
const int N=80000;
int n,x,s[N],top;
long long ans;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&x);
        while(top&&s[top]<=x)top--;
        ans+=top;//栈底从1开始,这样top就是元素,很方便
        s[++top]=x;
    }
    printf("%lld",ans);
    return 0;
}
原文地址:https://www.cnblogs.com/zzyh/p/6852042.html