UVA

You live in a village but work in another village. You decided to follow the straight path between your
house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to
the right of A, and all the rivers lie between them.
Fortunately, there is one “automatic” boat moving smoothly in each river. When you arrive the
left bank of a river, just wait for the boat, then go with it. You’re so slim that carrying you does not
change the speed of any boat.
Days and days after, you came up with the following question: assume each boat is independently
placed at random at time 0, what is the expected time to reach B from A? Your walking speed is
always 1.
To be more precise, for a river of length L, the distance of the boat (which could be regarded as a
mathematical point) to the left bank at time 0 is uniformly chosen from interval [0, L], and the boat
is equally like to be moving left or right, if it’s not precisely at the river bank.
Input
There will be at most 10 test cases. Each case begins with two integers n and D, where n (0 ≤ n ≤ 10)
is the number of rivers between A and B, D (1 ≤ D ≤ 1000) is the distance from A to B. Each of the
following n lines describes a river with 3 integers: p, L and v (0 ≤ p < D, 0 < L ≤ D, 1 ≤ v ≤ 100). p
is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the
boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last
test case is followed by n = D = 0, which should not be processed.
Output
For each test case, print the case number and the expected time, rounded to 3 digits after the decimal
point.
Print a blank line after the output of each test case.
Sample Input
1 1
0 1 2
0 1
0 0
Sample Output
Case 1: 1.000
Case 2: 1.000

题意:有个人每天要去公司上班,每次会经过N条河,家和公司的距离为D,默认在陆地的速度为1,给出N条河的信息,包括起始坐标p,宽度L,以及船的速度。船会往返在河的两岸,人到达河岸是,船的位置是随机的(包括方向)。问说人达到公司所需要的期望时间。

题解:由于有方向我们单纯算过河时间的话,最快的是l/v,最慢的可能是3l/v,期间的时间是线性的,所以期望就是4l/2v=2l/v,加上陆地的单位时间就可以了

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std ;
typedef long long ll;
const int N=100+10;
int main() {
    int cas = 1, n;
    double d, p, l, v;
    while(~scanf("%d%lf",&n,&d)) {
        if(n == 0 && d == 0) break;
        for(int i = 0 ;i < n; i++) {
            scanf("%lf%lf%lf",&p,&l,&v);
            d = d - l + l * 2 / v;
        }
       printf("Case %d: %.3f

", cas++, d);
    }
    return 0;
}
代码
原文地址:https://www.cnblogs.com/zxhl/p/5129961.html