POJ 1861:Network(最小生成树&&kruskal)

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13266   Accepted: 5123   Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

这题我就不吐槽了。

例子都是错的。。我没看讨论区。。

一直不知道。

浪费我那么多时间调试。

我去。

各种吐血。

。我也逗比。。

例子明显的出现环。。

正确的例子应该是:

1

3

1 2

1 3

3 4



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;

const int maxn1 = 15050;//边数的最大值
const int maxn2 = 1050;//顶点个数的最大值
int f[maxn2];//f[i]为顶点i在集合对树中的根节点
int s[maxn1];//记录选择的边的序号
int n, m;//集线器的个数。 边的个数
int cnt;//选择的边的数目
int ans;//记录最大的长度

struct Edge
{
    int u;
    int v;
    int len;
};
Edge edge[maxn1];//边的数组

bool cmp(Edge a, Edge b)//按长度从小到大的排序
{
    return a.len<b.len;
}

void init()//初始化
{
    for(int i=0; i<=n; i++)
        f[i] = i;
}

int find(int x)//并查集的find函数
{
    return f[x] == x?

x:f[x]=find( f[x] ); } void kruskal() { int x, y; cnt = 0; for(int i=1; i<=m; i++) { x = find( edge[i].u ); y = find( edge[i].v ); if( x==y ) continue; f[y] = x; ans = edge[i].len; cnt++; s[cnt] = i; if( cnt>=n-1 ) break; } } void output()//输出函数 { printf("%d ", ans); printf("%d ", cnt); for(int i=1; i<=cnt; i++) printf("%d %d ", edge[ s[i] ].u, edge[ s[i] ].v); } int main() { while(scanf("%d%d", &n, &m)!=EOF) { init(); for(int i=1; i<=m; i++) scanf("%d%d%d", &edge[i].u, &edge[i].v, &edge[i].len); sort( edge+1, edge+m+1, cmp ); kruskal(); output(); } return 0; }









原文地址:https://www.cnblogs.com/zsychanpin/p/6889090.html