(字母二叉树) B

Description


Figure 1

Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem.

A binary tree of letters may be one of two things:
  1. It may be empty.
  2. It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters:
  1. Empty trees are omitted completely.
  2. Each node is indicated by
    • Its letter data,
    • A line segment down to the left to the left subtree, if the left subtree is nonempty,
    • A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.

The preorder traversal of a tree of letters satisfies the defining properties:
  1. If the tree is empty, then the preorder traversal is empty.
  2. If the tree is not empty, then the preorder traversal consists of the following, in order
    • The data from the root node,
    • The preorder traversal of the root's left subtree,
    • The preorder traversal of the root's right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:

The root's data comes later in the alphabet than all the data in the nodes in the left subtree.

The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree.

The problem:

Consider the following sequence of operations on a binary search tree of letters

Remove the leaves and list the data removed
Repeat this procedure until the tree is empty
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree

by removing the leaves with data

BDHPY
CM
GQ
K

Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.

Input

The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.

The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*').

The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.

Output

For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

Sample Input

BDHPY
CM
GQ
K
*
AC
B
$

Sample Output

KGCBDHQMPY
BAC

具体思路:

将每一层的先整合到一块,然后再从最后一个字母开始遍历,大于当前字母就一直向右放,知道出现最后一个的右子为空的时候就直接将当前的字母放到他的下面,小于的时候是同理的,最后在直接用一个递归按照先序输出的方式输出就好了。。。

理解了本题其实再回来看看是很水的。。。 

#include<iostream>
#include<string>
#include<cstring>
using namespace std;

struct BiTree
{
    char data;
    BiTree *lchild;
 BiTree *rchild;//分别指向左右子树
} ;

BiTree *CreateBiTree(char ch)
{
    BiTree *leaf=new BiTree;  //  [sizeof(BiTree)]
    leaf->data=ch;
    leaf->lchild=NULL;  
    leaf->rchild=NULL;
    return leaf;
}

BiTree *InsertBiTree(char ch,BiTree *T)//ch为当前字符,T为树根
{
// cout<<"ch:"<<ch<<endl;
    BiTree *leaf=T;
 
    if(T==NULL)
    {
        T=CreateBiTree(ch);
 // cout<<"T***************"<<T->data<<endl;
        return T;
    }
// cout<<"T***************"<<T->data<<endl;
    while(leaf)
    {
        if(leaf->data>ch)//当当前字符比根的字符小的时候   
        {
            if(leaf->lchild==NULL)
            {
                leaf->lchild=CreateBiTree(ch);
                break;
            }
            else
                leaf=leaf->lchild;
        }
        else //当当前字符比根的字符大的时候
  {
   if(leaf->rchild==NULL)
   {
    leaf->rchild=CreateBiTree(ch);
    break;
   }
   else
    leaf=leaf->rchild;
  }
    }
    return T;
}

void Preorder(BiTree *T)//将整合后的树进行前序输出
{
    if(T)
    {
        cout<<T->data;
        Preorder(T->lchild);
        Preorder(T->rchild);
    }
}

int main()
{
    string str,s;
    int i,len;
 BiTree *Root=NULL;
    while(1)
    {
  while(cin>>s&&s!="*"&&s!="$")//输入字符串后整合在str中
  {
   str=str+s;
  // cout<<"str:"<<str<<endl;
  }
  // cin>>str;
        len=str.length();
        for(i=len-1;i>=0;i--)
            Root=InsertBiTree(str[i],Root);
        Preorder(Root);
        cout<<endl;    
        if(s=="$")
            break;
        Root=NULL;
        str.erase();
 // cout<<"=================================================="<<endl<<endl;
    }
    return 0;
}




 

若要使用递归,只需将BiTree *InsertBiTree(char ch,BiTree *T)稍作修改即可:

BiTree *InsertBiTree(char ch,BiTree *T)
{
    if(T==NULL)
    {
        T=new BiTree ;
        T->data=ch;
        T->lchild=NULL;
        T->rchild=NULL;
        return T;
    }
    if(T->data>ch)
    {
        if(T->lchild==NULL)
        {
            T->lchild=new BiTree ;
            T->lchild->data=ch;
            T->lchild->lchild=NULL;
            T->lchild->rchild=NULL;
            return T;
        }
        else
            T->lchild=InsertBiTree(ch,T->lchild);
    }
    else
    {
        if(T->rchild==NULL)
        {
            T->rchild=new BiTree;
            T->rchild->data=ch;
            T->rchild->lchild=NULL;
            T->rchild->rchild=NULL;
            return T;
        }
        else
            T->rchild=InsertBiTree(ch,T->rchild);
    }
    return T;
}


 

原文地址:https://www.cnblogs.com/zswbky/p/5432103.html