HDU 1069 Monkey and Banana (DP)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2599    Accepted Submission(s): 1345

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

 

Source
 

 

Recommend
JGShining
题意给你一些砖头的长宽高,让你去堆出最大高度,长宽高可旋转
题解;就是求出一个最长上升子序列,但是此时没有可比性,这时可以先排序,再对单边进行LIS,记得要列举出所有情况
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
#define SZ(x) ((int)(x).size())
typedef long long ll;
typedef pair<int,int> PII;
const ll mod=1000000007;
ll gcd(ll a,ll b) { return b?gcd(b,a%b):a;}
// head
#define MAX 1005
struct niu
{
    int x,y,high;
    int dp;
}b[MAX];
bool cmp(const niu& a,const niu& b)
{
    if(a.x!=b.x)return a.x<b.x;
    else return a.y<b.y;
}
int main()
{
    ios_base::sync_with_stdio(0);
    cin.tie(0);
    int n;
    int t=1;
    while(cin>>n)
    {
        if(n==0)break;
        int k=0;
        for(int i=0;i<n;i++)
        {
            int x,y,z;
            cin>>x>>y>>z;
            //把给出的block放置的所有可能放进block[]中,这样就可以解决有无限块的问题
            b[k].x=x,b[k].y=y,b[k].high=z,k++;
            b[k].x=x,b[k].y=z,b[k].high=y,k++;
            b[k].x=y,b[k].y=x,b[k].high=z,k++;
            b[k].x=y,b[k].y=z,b[k].high=x,k++;
            b[k].x=z,b[k].y=x,b[k].high=y,k++;
            b[k].x=z,b[k].y=y,b[k].high=x,k++;
        }
        sort(b,b+k,cmp);
        int res=0;
        for(int i=0;i<k;i++)
        {
            b[i].dp=b[i].high;
            for(int j=0;j<i;j++)
            {
                if(b[j].x<b[i].x&&b[j].y<b[i].y)
                    b[i].dp=max(b[i].dp,b[j].dp+b[i].high);
            }
            res=max(res,b[i].dp);
        }
        cout<<"Case "<<t<<": maximum height = "<<res<<endl;
        t++;
    }
}
原文地址:https://www.cnblogs.com/zhgyki/p/9494351.html