1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28


long long输出是%lld
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
#include<string.h>
#include<cstdio>
#include<cmath>
using namespace std;

struct Node
{
    long long Galleon;
    int Sickle,Knut;
};
void add(Node&A,Node&B)
{
    Node sum;
    int temp=0;
    sum.Knut=A.Knut+B.Knut;
    if(sum.Knut>=29)
    {
        sum.Knut-=29;
        temp=1;
    }
    sum.Sickle=A.Sickle+B.Sickle+temp;
    temp=0;
    while(sum.Sickle>=17)
    {
        sum.Sickle-=17;
        temp++;
    }
    sum.Galleon=A.Galleon+B.Galleon+temp;
    cout<<sum.Galleon<<"."<<sum.Sickle<<"."<<sum.Knut<<endl;
}



int main()
{
    Node A[2];
    char c;
    for(int i=0;i<2;i++)
       // cin>>A[i].Galleon>>c>>A[i].Sickle>>c>>A[i].Knut;
        scanf("%lld.%d.%d",&(A[i].Galleon),&(A[i].Sickle),&(A[i].Knut));
    //cout<<A[0].Galleon<<" "<<A[0].Sickle<<" "<<A[0].Knut<<endl;
    add(A[0],A[1]);

    return 0;
}
 
原文地址:https://www.cnblogs.com/zhanghaijie/p/10324875.html