ACM入门(1)——数据结构——并查集

ACM入门(1)——数据结构——并查集
                                                                并查集
一、检索某元素属于哪个集合(find()函数)
二、合并两个集合(union()函数)  
能够查找某个元素属于哪个集合(即“查”),同时能够实现集合的合并(即“并”),这样的数据结构,我们称之为并查集。

并查集的实现:(C/C++)
#define max_size 元素个数
int parent[max_size];//用memset(parent,-1,sizeof(parent));初始化
int find(int x)
{
if(parent[x]>0)
  parent[x]=find(parent[x]);//递归查找,同时起到了压缩路径的作用
return parent[x]>0? parent[x]:x;//返回父亲节点,根节点返回自身
}
void union_set(int x,int y)
{
x=find(x),y=find(y);//查找父亲节点
if(x!=y)//合并时不能是相同父亲节点的
{
  if(parent[x]<parent[y])//比较大小,小的连到大的上
  {
    parent[x]+=parent[y];
    parent[y]=x;
  }
   else
  {
    parent[y]+=parent[x];
     parent[x]=y;
   }
}
}
举个例子:
Hdu1856
                                                    More is better
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 803    Accepted Submission(s): 290

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
41 23 45 61 641 23 45 67 8

Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
代码如下:(c++)
#include<iostream>
using namespace std;
int parent[10000001],mymax;
int find(int x)
{
       if(parent[x]>0)
              parent[x]=find(parent[x]);//根节点以负数表示,同时绝对值表示集合元素个数
       return parent[x]>0? parent[x]:x;
}
void union_set(int x,int y)
{
       x=find(x),y=find(y);
       if(x!=y)
       {
              if(parent[x]<parent[y])//注意根节点均为负的
              {
                     parent[x]+=parent[y];
                     mymax=mymax<parent[x]? mymax:parent[x];
                     parent[y]=x;
              }
              else
              {
                     parent[y]+=parent[x];
                     mymax=mymax<parent[y]? mymax:parent[y];
                     parent[x]=y;
              }
       }
}
int main()
{
       int n;
       while(cin>>n)
       {
              if(n==0)
              {
                     cout<<"1"<<endl;
                     continue;
              }
              memset(parent,-1,sizeof(parent));//数组初始化为-1;
              mymax=0;
              int i,a,b;
              for(i=0;i<n;i++)
              {
                     cin>>a>>b;
                     union_set(a,b);
              }
              cout<<-mymax<<endl;//最大集合根节点值的相反数即为所求
       }
       return 0;
}

原文地址:https://www.cnblogs.com/zdcaolei/p/2122949.html