POJ 1941 The Sierpinski Fractal

总时间限制: 1000ms 内存限制: 65536kB

描述

Consider a regular triangular area, divide it into four equal triangles of half height and remove the one in the middle. Apply the same operation recursively to each of the three remaining triangles. If we repeated this procedure infinite times, we'd obtain something with an area of zero. The fractal that evolves this way is called the Sierpinski Triangle. Although its topological dimension is 2, its Hausdorff-Besicovitch dimension is log(3)/log(2)~1.58, a fractional value (that's why it is called a fractal). By the way, the Hausdorff-Besicovitch dimension of the Norwegian coast is approximately 1.52, its topological dimension being 1. 

For this problem, you are to outline the Sierpinski Triangle up to a certain recursion depth, using just ASCII characters. Since the drawing resolution is thus fixed, you'll need to grow the picture appropriately. Draw the smallest triangle (that is not divided any further) with two slashes, to backslashes and two underscores like this: 

 /
/__

To see how to draw larger triangles, take a look at the sample output.

输入

The input contains several testcases. Each is specified by an integer n. Input is terminated by n=0. Otherwise 1<=n<=10 indicates the recursion depth.

输出

For each test case draw an outline of the Sierpinski Triangle with a side's total length of 2ncharacters. Align your output to the left, that is, print the bottom leftmost slash into the first column. The output must not contain any trailing blanks. Print an empty line after each test case.

样例输入

3
2
1
0

样例输出

       /
      /__
     /  /
    /__/__
   /      /
  /__    /__
 /  /  /  /
/__/__/__/__

   /
  /__
 /  /
/__/__

 /
/__

解题思路

一开始总是以小三角形为单位,百思不得其解。看了一眼网上的思路之后恍然大悟要用数组做,递归的整体过程也写的很轻松,然后被各种换行空字符bug折磨,调了一个多小时orz。

AC代码

#include<iostream>
#include<cstring>
using namespace std;

char map[1038][2058];//x向上延展是行,y向右延展是列

void GetMap(int t, int x, int y)//x,y是每个三角形的起点
{
    if (t == 1)
    {
        map[x][y] = '/', map[x][y+1] = '_', map[x][y+2] = '_', map[x][y+3] = '\';
        map[x + 1][y] = ' ', map[x + 1][y + 1] = '/', map[x + 1][y + 2] = '\';
    }
    else
    {
        GetMap(t - 1, x, y);
        GetMap(t - 1, x, (1 << t) + y);
        GetMap(t - 1, (1 << (t - 1)) + x, (1 << (t - 1)) + y);
    }
}

void Draw(int t)
{
    int m = (1 << t) + 1;
    for (int i = 1<<t; i > 0; i--)
    {
        for (int j = 1; j <= m; j++)
        {
            if (map[i][j])
            {
                cout << map[i][j];
            }
            else cout << ' ';
        }
        cout << endl;
        m++;
    }
}

int main()
{
    int t;
    int num = 1;
    while (true)
    {
        cin >> t;
        if (t == 0)break;
        GetMap(t,1,1);
        if(num > 1) cout << endl;
        num++;
        Draw(t);
    }
    //system("pause");
    return 0;
}
原文地址:https://www.cnblogs.com/yun-an/p/10921075.html