hdu1712 分组背包

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5964    Accepted Submission(s): 3251


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 
Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
Sample Output
3 4 6
题目大意:ACboy要开始选课了,上一门课能够获得的收益和他上这门课的时间是有关的,然后给你若干门课,让你帮他进行选课,
每一门课自然是只能选择一个课程时长,问你如何选择,才能使ACboy获得的受益最大。
思路分析:这是自己做的第一道分组背包的题目,抽象一下,背包容量相当于ACboy拥有的时间,然后给你若干组物品(课程),每一组
物品里面有着若干个物品(课程时间),一组里面的物品只能选择一个,这么一抽象,标准的分组背包问题,相当于若干组物品的01背包
问题,但是要注意,v的循环一定要放在组内物品循环之外,这样才能保证一个组的物品只用了一个,另外,内层循环要有一个判断,判断是
否满足v-cost>=0,否则会出现数组越界,报错。
代码:#include <iostream>
#include <stack>
#include <cstdio>
#include <cstring>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=105;
int a[maxn][maxn];
int f[maxn];
int main()
{
   int n,m;
   while(scanf("%d%d",&n,&m)&&(n||m))
   {
       memset(f,0,sizeof(f));
       for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        scanf("%d",&a[i][j]);
       for(int i=1;i<=n;i++)
       {
           for(int j=m;j>=0;j--)
           {
               for(int k=1;k<=m;k++)
               {
                  if(j-k>=0)
                   f[j]=max(f[j],f[j-k]+a[i][k]);
               }
           }
       }
     cout<<f[m]<<endl;
   }
}
原文地址:https://www.cnblogs.com/xuejianye/p/5426377.html