字符串系列——Immediate Decodability

 Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file.Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that groupare immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable


托了好久才又继续刷题,电脑终于买过来了。。。。

废话不说,看题。。。

字符串系列还没刷完,我真是退步了,最近没刷都有点生疏了。。。

题就是判断所给10串里面有没有某个串是另一串的前缀。

本来思路是截取字符串再对比,不过老是实现不了,字符串这部分有空得复习复习了。。。

后来看网上人家用了一个非常方便的办法,就是strstr函数,判断一个字符串是否包含在另一个字符串里面,返回第一个字符的地址,然后与其第一个字符地址对比

代码大大缩短了。。。


代码(未AC):

#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	int cnt = 1;
	while (1)
	{
		char ch[100][100], tmp;
		int n = 0;

		for (int i = 0; cin >> ch[i]; i++)
		{
			if (strcmp(ch[i], "9") == 0)
				break;
			n++;
		}

		bool jd = true;
		for (int i = 0; i < n; i++)
			for (int j = i + 1; j < n; j++)
				if (strstr(ch[i], ch[j]) == &ch[i][0] || strstr(ch[j], ch[i]) == &ch[j][0])
				{
					jd = false;
					break;
				}

		if (jd)
			cout << "Set " << cnt++ << " is immediately decodable" << endl;
		else
			cout << "Set " << cnt++ << " is not immediately decodable" << endl;
	}
	return 0;
}


Time limit exceeded。。。

测试是没有错误的,但是我检查后发现一个问题就是这程序没有退出点。。。

修改后AC了。。。

#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	int cnt = 1;
	char temp[100];
	while (cin >> temp)
	{
		if (temp[0] == '9')
			break;
		char ch[100][100], tmp;
		int n = 1;
		strcpy(ch[0], temp);

		for (int i = 1; cin >> ch[i]; i++)
		{
			if (strcmp(ch[i], "9") == 0)
				break;
			n++;
		}
		bool jd = true;
		for (int i = 0; i < n; i++)
			for (int j = i + 1; j < n; j++)
				if (strstr(ch[i], ch[j]) == &ch[i][0] || strstr(ch[j], ch[i]) == &ch[j][0])
				{
					jd = false;
					break;
				}

		if (jd)
			cout << "Set " << cnt++ << " is immediately decodable" << endl;
		else
			cout << "Set " << cnt++ << " is not immediately decodable" << endl;
		memset(temp, 0, sizeof(temp));
	}
	return 0;
}


各种不容易啊,有空要多刷了,不能停了。。。。



原文地址:https://www.cnblogs.com/xinyuyuanm/p/2979655.html