POJ 3273 Monthly Expense(二分搜索)

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
 
思路
1. 二分法
 
代码
Source Code

Problem: 3273        User: blazing
Memory: 612K        Time: 329MS
Language: C++        Result: Accepted
Source Code
#include <iostream>
using namespace std;
const int MAXN = 120000;
int input[MAXN];
int n, k;
int low, high;
int curMax, curSum;
int binarySearch(const int & low, const int &high) {
    if(low > high) return low;
    int mid = (low + high)>>1;
    //cout << "mid : " << mid << endl;
    int count = 0, sum = 0;
    for( int i = 0; i < n; i ++ ) {
        if( sum+input[i] <= mid ) {

        }else{
            count += 1;
            sum = 0;
        }
        sum += input[i];
    }
    count ++;
    if( count > k ) 
        binarySearch(mid+1, high);
    else
        binarySearch(low, mid-1);
    
}
int main() {
    //freopen("E:\Copy\ACM\poj\3273_v1\in.txt", "r", stdin);
    while( cin >> n >> k ) {
        curMax = 0, curSum = 0;
        for( int i = 0; i < n; i ++ ) {
            cin >> input[i];
            curMax = max( curMax, input[i]);
            curSum += input[i];
        }

        int curSize = binarySearch( curMax, curSum );
        
        cout << curSize << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/xinsheng/p/3599467.html