hdu1130 How Many Trees?(Catalan+高精)

Problem Description

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) < label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?

Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input
1
2
3

Sample Output
1
2
5

Source
UVA

分析:
给出结点数,求形态不同的二叉树
Catalan经典模型

tip

我要有逼格
我要重载运算符(然而完全是多余)

第一次交上去是PE
我整个人都是mb的
后来把输出改成了这个样子,就没有问题了

 for (int i=a[n].l;i>=1;i--)
     printf("%d",a[n].s[i]);
 puts("");

习惯了忽略行末空格
所以在做UVa的题的时候就比较难受

//这里写代码片
#include<cstdio>
#include<cstring>
#include<iostream>

using namespace std;

struct node{
    int l,s[102];
    void clear()
    {
        memset(s,0,sizeof(s));
    }
};
node a[102];

node operator *(const node &a,const int &x)
{
    node b;
    b.clear();
    int ll=a.l;
    int d=0;
    for (int i=1;i<=ll;i++)
    {
        b.s[i]=a.s[i]*x+d;
        d=b.s[i]/10;
        b.s[i]%=10;
    }

    while (d)
    {
        b.s[++ll]=d;
        d=b.s[ll]/10;
        b.s[ll]%=10;        
    }

    b.l=ll;
    return b;
}

node operator /(const node &a,const int &x)
{
    node b;
    b.clear();
    int d=0;
    for (int i=a.l;i>=1;i--)
    {
        int t=d*10+a.s[i];
        b.s[i]=t/x;
        d=t%x;
    }

    int ll=a.l;
    while (b.s[ll]==0) ll--;

    b.l=ll;
    return b;
}

void Catalan()
{
    a[1].clear();
    a[1].l=1; a[1].s[1]=1;
    for (int i=2;i<=100;i++)
    {
        a[i]=a[i-1]*(4*i-2);
        a[i]=a[i]/(i+1);
    }
}

int main()
{
    Catalan();
    int n;
    int cnt=0;
    while (scanf("%d",&n)!=EOF)
    {
        for (int i=a[n].l;i>=1;i--)
            printf("%d",a[n].s[i]);
        puts("");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wutongtong3117/p/7673054.html