PAT 1017 Queueing at Bank (模拟)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

思路

把每个时间都转换为秒,方便比较大小。

按照到达时间进行排序,把到达时间大于17*3600的直接不予考虑。

用一个vector记录每个窗口可以接待用户的时间。

​ 一开始时,每个窗口的可以接待用户的时间都是8*3600

​ 从第一个顾客开始扫描到最后一个顾客,令t为所有窗口中最早结束的时间,c[i].t为第i个顾客到达的时间,c[i].cost为第i个顾客办理业务的时间,sum记录所有顾客等待的时间,则

​ 若c[i].t > t ,则 t = c[i].t + c[i].cost

​ 否则,t += c[i].cost, sum += t - c[i].t

答案就是sum/60.0/N (N为删除到达时间在17*3600之后的顾客人数)

代码

#include <stdio.h>
#include <string>
#include <stdlib.h>
#include <iostream>
#include <vector>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <map>
#include <queue>
#include <functional>
#include <limits.h> 
using namespace std;

struct customer{
	int t;
	int cost;
	bool operator< (customer a) const {
		return t < a.t;
	}
};

int N, K;
customer c[10000 + 10];
priority_queue<int, vector<int>, greater<int> > myq;
vector<int> myv;
int sum = 0;
int main() {
	//input
	cin >> N >> K;
	int h, m, s, cost;
	for(int i = 0; i < N; i++){
		scanf("%d:%d:%d%d", &h, &m, &s, &cost);
		c[i].t = h * 3600 + m * 60 + s;
		c[i].cost = min(60 * 60, cost * 60);
	}
	
	// init
	sort(c, c + N);
	for(int i = N - 1; i >= 0; i--){
		if(c[i].t > 17 * 3600)	N--;
	}
	for(int i = 0; i < K; i++){
		myv.push_back(8 * 3600);
	}
	
	// do it
	for(int i = 0; i < N; i++){
		vector<int>::iterator j = min_element(myv.begin(), myv.end());
		if(*j < c[i].t){
			*j = c[i].t + c[i].cost;
		}
		else{
			sum += *j - c[i].t;
			*j += c[i].cost;
		}
	}
	printf("%0.1lf", sum / 60.0 / N);
	return 0; 
}
原文地址:https://www.cnblogs.com/woxiaosade/p/12370817.html