HDU

HDU - 1702

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. 
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy." 
The problems of the monster is shown on the wall: 
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 
and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

InputThe input contains multiple test cases. 
The first line has one integer,represent the number oftest cases. 
And the input of each subproblem are described above.OutputFor each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

//标准的stl题,队列和栈

import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;
import java.util.Stack;

public class Main {
    static Queue<Integer> queue = new LinkedList<Integer>();
    static Stack<Integer> st = new Stack<Integer>();
    static Scanner sc = new Scanner(System.in);
    public static void main(String[] args) {
        int n=0;
        n = sc.nextInt();
        while(n-->0) {
            int m = sc.nextInt();
            String s = sc.next();
            if(s.equals("FIFO")) {
                for (int i = 0; i < m ; i++) 
                FIFO();
                queue.clear();
            }else
            {
                for (int i = 0; i < m ; i++) 
                FILO();
                st.clear();
            }            
        }
    }


    private static void FILO() {
        int flag = 0;
        String s1 = sc.next();
        if(s1.equals("IN")) {
            flag = sc.nextInt();
            st.push(flag);
        }
        else {
            if(st.isEmpty()) {
                System.out.println("None");
            }else {
                System.out.println(st.pop());    
            }
        }
    }

    private static void FIFO() {
        int flag = 0;
        String s1 = sc.next();
        if(s1.equals("IN")) {
            flag = sc.nextInt();
            queue.add(flag);
        }
        else {
            if(queue.isEmpty()) {
                System.out.println("None");
            }else{
                System.out.println(queue.poll());                
            }
        }
        
    }


}
原文地址:https://www.cnblogs.com/upstart/p/8848423.html