Lowest Bit(虽然很简单)

Lowest Bit

Time Limit: 1000MS Memory limit: 65536K

题目描述

Given an positive integer A (1 <= A <= 100), output the lowest bit of A. 

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
 
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

输入

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

输出

For each A in the input, output a line containing only its lowest bit.

示例输入

26
88
0

示例输出

2
8

#include <stdio.h>

int main()
{	
	int n;
	int sum;
	while(scanf("%d",&n), n != 0)
	{
		sum = 1;
		while( (n & 1) == 0)//这里(n&1)一定要括起来。。&优先级不够高啊。。费了很大劲才知道的。。好吧。我承认我很低级。。
		{
			n /= 2;
			sum *= 2;
		}
		printf("%d\n",sum);
	}
	return 0;
}






原文地址:https://www.cnblogs.com/tanhehe/p/2883529.html