HDU_1003 Max Sum

点击打开链接

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 255311    Accepted Submission(s): 60666


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
    题解:点击打开链接

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
#include<iostream>
using namespace std;
int main()
{
    int N,n,a,first,last;
 cin>>N;
 for(int i=1;i<=N;i++)
 {
     cin>>n;
     int max=-1000,sum=0,k=1;
     for(int j=1;j<=n;j++)
    {
        cin>>a;
         sum=sum+a;
         if(sum>max)//如果当前的最大值大于以前的最大值  更新 sum 与max 都是一种计算的结果和属性相同
         {
         first=k;
         last=j;
         max=sum;
         }
         if(sum<0)
         //else
         {
             k=j+1;
             sum=0;
         }
     }
     cout<<"Case "<<i<<":"<<endl;
     cout<<max<<" "<<first<<" "<<last;
     if(i==N)
         cout<<endl;
     else
         cout<<endl<<endl;
 }
 return 0;
}

#include <stdio.h>
int main()
{
    int z,n,max,sum;
    int a,b,A,B,t;
    scanf("%d",&z);
    for(int k=1;k<=z;k++)
    {
        scanf("%d",&n);
        sum = max = -1001;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&t);
            if(sum+t < t)
                sum = t , a = b = i;      //a、b记录当前连续子序列的起始、结束位置
            else
                sum += t , ++b;
            if(max < sum)//附一篇另一种代码,在这儿不知道这个if语句的作用
                max = sum , A = a , B = b;
        }
        printf("Case %d:
%d %d %d
",k,max,A,B);
        if(k-z) puts("");
    }
	return 0;
}

原文地址:https://www.cnblogs.com/sxy201658506207/p/7586283.html