SDUT _2117 数据结构实验之链表二:逆序建立链表

点击打开链接

数据结构实验之链表二:逆序建立链表

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Example Input

10
11 3 5 27 9 12 43 16 84 22 

Example Output

22 84 16 43 12 9 27 5 3 11 

Hint

不能使用数组!

Author

#include <iostream>
using namespace std;
struct node
{
	int num;
	node *next;
};
int main()
{
	node *head,*tail,*p,*q;
	int n;
	cin>>n;
	tail=new node;//必须动态建立一个
	tail->next=NULL;//实际上开辟了11个节点,最后一个的NUM没有赋值text为NULL
		head=tail;
	while(n--)
	{
		p=new node;
		cin>>p->num;
		p->next=head;
		head=p;
	}
	q=head;
	while(q->next->next!=NULL)
	{
		cout<<q->num<<' ';
	q=q->next;
	}
	cout<<q->num<<endl;;
	return 0;
}


/***************************************************
User name: YT1658506207邵雪源
Result: Accepted
Take time: 0ms
Take Memory: 200KB
Submit time: 2017-07-31 10:42:35
****************************************************/


原文地址:https://www.cnblogs.com/sxy201658506207/p/7586274.html