[2012山东ACM省赛] The Best Seat in ACM Contest (模拟)

The Best Seat in ACM Contest

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Cainiao is a university student who loves ACM contest very much. It is a festival for him once when he attends ACM Asia Regional Contest because he always can find some famous ACMers there.
Cainiao attended Asia Regional Contest Fuzhou Site on November 20, 2011. After he got seat map, he wanted to know which seat is the best one.
Cainiao have joined so many QQ Group about ACM/ICPC that he is almost familiar with the strength of each team. In his mind, the value of a seat is defined as following:

1. Strength of each team can be expressed as a positive integer.
2. The value of a seat is related to the adjacent seat (up/down/left/right, only four directions being considering).
3. For an adjacent seat, if the strength of this team is stronger than yours, the absolute value of difference of two teams should be added to your seat, otherwise, the absolute value of difference should be subtracted from your seat.
4. If the adjacent seat is empty (which means you are located at the most left/right/up/down), the value of your seat should be subtracted 1.
5. The best one in a contest is the seat that has the highest value.
6. The initial value of the seat is ZERO.

For example, there are 12 ( 3 X 4 ) teams in a contest, the strength of each team is as figure (a), and then you can calculate the value of each seat as figure (b).

 

输入

Input contain a positive integer T( T <=50 ) in the first line, which means T cases.
The first line of each case contains two positive integers N and M (3 <= N, M <= 20) which means the row and column number of the teams, then N rows following, each line contains M positive integers that represent the strengths of the teams.

输出

For each case, first output the case number, and then output the value and row number and column number of the best seat in one line for each case. 
If there are multiple solutions for one case, you should output the seat whose row number is largest and only output the seat whose column number is largest if still overlapping.

示例输入

13 41 5 3 46 3 3 44 3 2 1

示例输出

Case 1: 7 1 1

提示

 

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛

解题思路:

按照题意说明模拟一下,计算各个座位的分值,输出分值最大的值,行号,列号,因为要求如果有多个相同的最大值,输出行最大,所以最后遍历数组时,要max<=小于等于号。

代码:

#include <iostream>
#include <string.h>
using namespace std;

int s[30][30];//存座位power
int d[30][30];//存分值

int main()
{
    int t;cin>>t;
    int c=1;
    int n,m;
    while(t--)
    {
        memset(d,0,sizeof(d));
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            cin>>s[i][j];
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            if(i-1<1)//上面
                d[i][j]--;
            else if(s[i][j]<s[i-1][j])
                d[i][j]+=(s[i-1][j]-s[i][j]);
            else
                d[i][j]-=(s[i][j]-s[i-1][j]);

            if(i+1>n)//下面
                d[i][j]--;
            else if(s[i][j]<s[i+1][j])
                d[i][j]+=(s[i+1][j]-s[i][j]);
            else
                d[i][j]-=(s[i][j]-s[i+1][j]);

            if(j-1<1)//左边
                d[i][j]--;
            else if(s[i][j]<s[i][j-1])
                d[i][j]+=(s[i][j-1]-s[i][j]);
            else
                d[i][j]-=(s[i][j]-s[i][j-1]);

            if(j+1>m)//右边
                d[i][j]--;
            else if(s[i][j]<s[i][j+1])
                d[i][j]+=(s[i][j+1]-s[i][j]);
            else
                d[i][j]-=(s[i][j]-s[i][j+1]);
        }
        int rr,cc;//行,列
        int max=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            if(max<=d[i][j])//注意这里是小于等于
            {
                max=d[i][j];
                rr=i;cc=j;
            }
        }
       cout<<"Case "<<c++<<": "<<max<<" "<<rr<<" "<<cc<<endl;
    }
    return 0;
}


 

原文地址:https://www.cnblogs.com/sr1993/p/3697747.html