L2-022 重排链表 (25 分)

L2-022 重排链表 (25 分)
 

给定一个单链表 L1​​→L2​​→⋯→Ln1​​→Ln​​,请编写程序将链表重新排列为 Ln​​→L1​​→Ln1​​→L2​​→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤)。结点的地址是5位非负整数,NULL地址用−表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址;Data是该结点保存的数据,为不超过1的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:

对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1

链表操作 把-1定义成100040方便倒腾

using namespace std;
#include <stdio.h>
#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
//#include <map>
//#include <set>
#include <sstream>
#include <algorithm>
int N, M, S;
//const int MAXN = , MAXM = 0;
//typedef long long ll;
const int si = 100100, nul = 100040;
int pre[si], nxt[si], v[si];
int anxt[si];

int main() {
    cin >> S >> N;
    pre[S] = S;
    //input
    for (int i = 0; i < N; i++) {
        int adr, val, n;
        cin >> adr >> val >> n;
        if(n == -1) {
            n = nul;
        }
        nxt[adr] = n;
        v[adr] = val;
        pre[n] = adr;
    }
    int head = S, back = pre[nul];
    int AS = -1, fl = 0;
    int e = 1, apre;
    
    while (1) {
        if (head == back) fl = 1;
        if (e) {
            if (AS == -1)  {
                AS = back;
            }
            else anxt[apre] = back;
            anxt[back] = -1;
            apre = back;
            back = pre[back];
        }
        else {
            anxt[apre] = head;
            anxt[head] = -1;
            apre = head;
            head = nxt[head];
        }
        e = 1 - e;
        if (fl) break;
    }
    //cout << endl;
    int crt = AS;
    while (crt != -1) {
        printf("%05d %d ", crt, v[crt]);
        if (anxt[crt] != -1) {
            printf("%05d", anxt[crt]);
        }
        else {
            printf("-1");
        }
        crt = anxt[crt];
        cout << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/smatrchen/p/10616131.html