UVa 490 Rotating Sentences

  先上题目:

 

 Rotating Sentences 

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"
  这一题的做法和矩阵的旋转很相似,不过这里是对字符操作。需要注意的是输入的这一段字符串,第一个字符串是在最右端,第二个在其左方,如此类推。
  这一题一开始把代码写复杂了,而且交上去以后一直都是wa,后来曾经想过是不是空格太多了,某一些地方不应该有空格,当时的分析如下图:

  当时认为红色的方格所在位置不能有空格,于是想办法做了出来,可是交上去还是wa。最后还是用回第一次的思路,并且在最后一行输出的结尾加了一个换行,然后就过了。

  这一题其实也是很简单的,只要中规中矩把代码写出来就可以过。

  下面上代码:

#include <stdio.h>
#include <string.h>

int main()
{
    char s[110][110],t[110];
    int i=0,j,n=-1,max=0;
    memset(s,' ',sizeof(s));
    while(gets(t))
    {
        n++;
        for(i=0;t[i]!='\0';i++) s[i][n]=t[i];
        if(max<i) max=i;
    }
    for(i=0;i<max;i++)
    {
        for(j=n;j!=-1;j--)
        {

putchar(s[i][j]); } printf(
"\n"); } return 0; }
原文地址:https://www.cnblogs.com/sineatos/p/2893522.html