九度OnlineJudge之1017:还是畅通工程

题目描述:                       

    某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
输入:                       

    测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
    当N为0时,输入结束,该用例不被处理。

输出:                       

    对每个测试用例,在1行里输出最小的公路总长度。

样例输入:                       
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
样例输出:                       
3
5
//典型的最小生成树解法
#include <algorithm>
#include <iostream>

#define N 101

using namespace std;

struct Edge
{
        int a,b;
        int cost;   
        
    bool operator < (const Edge& A)const
       { return  cost<A.cost;   }     

}Edge[6000];

int Tree[N];

int findRoot(int x)
{
    if(Tree[x]==-1)
    return x;
    else
    {
        int tmp = findRoot(Tree[x]);        
        Tree[x] = tmp;       
        return tmp;                     
    }          
}


int main()
{
    int n;
    while(cin>>n,n!=0)
    {
      for(int i=1;i<=n*(n-1)/2;i++)
      cin>>Edge[i].a>>Edge[i].b>>Edge[i].cost;                                          
     
     sort(Edge+1,Edge+n*(n-1)/2+1);//按照权值从小到大给边排序
     
     for(int i=1;i<=n;i++)  Tree[i] = -1;
     
     int ans = 0;//最小生成树权值和
     
     for(int i=1;i<=n*(n-1)/2;i++)
     {
            int a = Edge[i].a;
            int b = Edge[i].b;
            int c = Edge[i].cost;
             a = findRoot(a); 
             b = findRoot(b);
             if(a!=b)
             {
               Tree[a] = b;
               ans += c;                                                                
             }    
                                        
     } 
     cout<<ans<<endl; 
     
     
                                       
    }
           
  //  system("PAUSE");
    return 0;
}
原文地址:https://www.cnblogs.com/riskyer/p/3318062.html