【dfs】POJ2386湖计数

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34735   Accepted: 17246

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

题解

这道题显然是一道入门搜索题

【涨涨自信2333】

只要八个方向dfs就好

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int n,m,ans;
int xx[9]={0,1,1,1,0,0,-1,-1,-1},
    yy[9]={0,1,-1,0,1,-1,0,1,-1};
char a[105][105];
bool map[105][105],vis[105][105];

void dfs(int a,int b)
{
    for(int i=1;i<=9;++i)
    {
        int x=xx[i]+a,y=yy[i]+b;
        if(map[x][y]&&!vis[x][y])
        {
            vis[x][y]=1;
            dfs(x,y);
        }
    }
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;++i)
    {
        scanf("%s",a[i]);
        for(int j=0;j<m;++j)
            if(a[i][j]=='W')map[i][j+1]=1;
    }
    for(int i=1;i<=n;++i)
        for(int j=1;j<=m;++j)
            if(map[i][j]&&!vis[i][j])
            {
                vis[i][j]=1;
                dfs(i,j);
                ans++;
            }
    printf("%d",ans);
}
原文地址:https://www.cnblogs.com/rir1715/p/6868952.html