HDU 1325 Is It A Tree? (并查集)

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25318    Accepted Submission(s): 5787


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 


Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 


Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 


Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 


Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 


Source
注意输入(当输入小于0结束)。树:空树或只有一个根节点、有向无环、除根节点外每个结点入度都为1。
有环的情况:要么没有节点入度为0,要么存在入度大于1的节点
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e4+5;
int par[maxn],in[maxn];
bool vis[maxn];
void init()
{
    for(int i=1;i<maxn;i++)
        vis[i]=false,par[i]=i,in[i]=0;
}
int find(int x)
{
    if(par[x]==x)
        return x;
    else
        return par[x]=find(par[x]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    par[x]=y;
}
bool same(int x,int y)
{
    return find(x)==find(y);
}
int main()
{
    int a,b,cas=0;
    while(cin>>a>>b,a>=0&&b>=0)
    {
        bool flag=false;
        init();
        if(!a&&!b)
        {
            cout<<"Case "<<++cas<<" is a tree."<<endl;
            continue;
        }
        while(a&&b)
        {
            if(same(a,b))
                flag=true;
            unite(a,b);
            in[b]++;
            vis[a]=vis[b]=true;
            cin>>a>>b;
        }
        int cnt=0;
        for(int i=1;i<maxn;i++)    
        {
            if(in[i]>1)//节点的入度大于1,说明不止一个父节点,违背树的性质
            {
                flag=true;
                break;
            }
            if(vis[i]&&par[i]==i)//是根节点(入度为0)
                cnt++;
        }
        cout<<"Case "<<++cas;
        if(flag)
            cout<<" is not a tree."<<endl;
        else
        {
            if(cnt==1)
                cout<<" is a tree."<<endl;
            else
                cout<<" is not a tree."<<endl;
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/orion7/p/7259470.html