ACM2026

/*

首字母变大写

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm i want to get an accepted
 
Sample Output
I Like Acm I Want To Get An Accepted
*/
#include<iostream> #include<cstring> int main() { using namespace std; char a[101],t; int i,l; while(1) { cin.getline(a,101); t='0'; l=strlen(a); a[0]=toupper(a[0]); for(i=1;i<l;i++) if(a[i-1]==' ') a[i]=toupper(a[i]); puts(a); } return 0; }

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    char ch[100];
    bool flag=0;
    char f;
    while(gets(ch)){
        int len=strlen(ch);
        f=ch[0]-32;
        cout<<f;
        for(int i=1;i<len;i++){
            if(flag==1){
                 f=ch[i]-32;
                 cout<<f;
                 flag=0;
            }
            else cout<<ch[i];
            if(ch[i]==' ') flag=1;
            
        }
        cout<<endl;
    }
}
原文地址:https://www.cnblogs.com/orangebook/p/3182221.html