1106 Lowest Price in Supply Chain (25 分)(DFS,BFS,树的遍历)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

题目大意:

提供一棵树,在树根处货物的价格为p,从根结点开始每往下一层,该层货物价格将会在父亲结点的价格上增加r%。求叶子结点出能获得的最低价格以及能提供最低价格的叶子结点数

分析:

dfs。保存深度的最小值mindepth,以及最小值下该深度的个数minnum。深度优先搜索参数为index和depth,不断遍历index结点的孩子结点,直到当前结点没有孩子结点为止return~

原文链接:https://blog.csdn.net/liuchuo/article/details/52214448

题解

i sum children
0 3 2 3 5
1 1 9
2 1 4
3 1 7
4 0 7
5 2 6 1
6 1 8
7 0 9
8 0 4
9 0 3

image

#include <bits/stdc++.h>

using namespace std;
const int maxn=100010;
const double INF=1e12;
vector<int> node[maxn];
int n,num=0;
double p,r,ans=INF;

void DFS(int index,int depth)
{
    if(node[index].size()==0){ //到达叶节点
        double price=p*pow(1+r,depth); //当前价格
        if(price<ans){  //如果低于全局最低价格
            ans=price;  //更新全局价格
            num=1;      //价格最低的叶子结点个数为1
        }else if(price==ans) //如果相等
            num++;      //价格最低的叶子结点个数加1
        return;
    }
    for(int i=0;i<node[index].size();i++)
        DFS(node[index][i],depth+1);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int k,child;
    cin>>n>>p>>r;
    r/=100;
    for(int i=0;i<n;i++){
        cin>>k;
        if(k!=0){
            for(int j=0;j<k;j++){
                cin>>child;
                node[i].push_back(child);
            }
        }
    }
    DFS(0,0);
    printf("%.4f %d\n",ans,num);
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15799601.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15799601.html