1079 Total Sales of Supply Chain (25 分)(dfs,bfs,树的遍历)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

生词

英文 解释
retailers 零售商
distributors 经销商
suppliers 供应商

题目大意:

给一棵树,在树根出货物的价格为p,然后从根结点开始每往下走一层,该层的货物价格将会在父亲结点的价格上增加r%,给出每个叶结点的货物量,求他们的价格之和~

分析:

树的遍历,可以采用dfs或者bfs两种方法。采用dfs,建立结构体数组保存每一个结点的孩子结点的下标,如果没有孩子结点,就保存这个叶子结点的data(销售的量)。深度优先遍历的递归出口,即当前下标的结点没有孩子结点的时候,就把ans += data(货物量)* pow(1 + r, depth)计算货物量*价格引起的涨幅百分比。如果有孩子结点,就dfs深度优先遍历每一个孩子结点,并且在当前depth层数的基础上+1。最后输出ans * p(销售价格),即总价格~

原文链接:https://blog.csdn.net/liuchuo/article/details/52205327

题解

i sum children
0 3 2 3 5
1 1 9
2 1 4
3 1 7
4 0 7
5 2 6 1
6 1 8
7 0 9
8 0 4
9 0 3

image
image

#include <bits/stdc++.h>

using namespace std;
const int maxn=100010;
struct node
{
    double data; //货物量
    vector<int> child;
}Node[maxn];
int n;
double p,r,ans=0;
void DFS(int index,int depth){
    if(Node[index].child.size()==0){ //到达叶节点
        ans+=Node[index].data*pow(1+r,depth); //累加叶节点货物的价格
        return;
    }
    for(int i=0;i<Node[index].child.size();i++)
        DFS(Node[index].child[i],depth+1); //递归访问子结点
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int k,child;
    cin>>n>>p>>r;
    r/=100;
    for(int i=0;i<n;i++){
        cin>>k;
        if(k==0)
            cin>>Node[i].data;
        else{
            for(int j=0;j<k;j++){
                cin>>child;
                Node[i].child.push_back(child);  //child为结点i的子结点
            }
        }
    }
    DFS(0,0);
    printf("%.1f\n",p*ans);
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15768723.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15768723.html