1005 Spell It Right (20 分)(字符串处理)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input

12345

Sample Output

one five

题解

#include <bits/stdc++.h>

using namespace std;
string str[10]={"zero","one","two","three","four",
                "five","six","seven","eight","nine"};
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    string s;
    int sum=0;
    vector<int> v;
    cin>>s;
    for(int i=0;i<s.length();i++){
        sum+=(s[i]-'0');
    }
    if(sum==0){
        cout<<"zero"; return 0;
    }
    while(sum){
        v.push_back(sum%10);
        sum/=10;
    }
    for(int i=v.size()-1;i>=0;i--)
    {
        if(i!=v.size()-1)```
            cout<<" "<<str[v[i]];
        else cout<<str[v[i]];
    }
}

柳神代码
柳神的代码还是极致优雅啊~

#include <iostream>
using namespace std;
int main() {
    string a;
    cin >> a;
    int sum = 0;
    for (int i = 0; i < a.length(); i++)
        sum += (a[i] - '0');
    string s = to_string(sum);
    string arr[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    cout << arr[s[0] - '0'];
    for (int i = 1; i < s.length(); i++)
        cout << " " << arr[s[i] - '0'];
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15510231.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15510231.html