POJ 2253 Floyd算法的巧妙改动

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 37130   Accepted: 11944

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


#include<iostream>
#include<math.h>
#include<iomanip>
#include <cstdio>
using namespace std;

struct coordinate
{
  double x,y;
}point[201];

double path[201][201];   //两点间的权值

int main()
{
	int i,j,k;

	int cases=1;
	while(cases)
	{


		int n;
		cin>>n;
		if(!n)break;

		for(i=1;i<=n;i++)
			cin>>point[i].x>>point[i].y;
//因为双向且对称,只用求一边距离
		for(i=1;i<=n-1;i++)
			for(j=i+1;j<=n;j++)
			{
				double x2=point[i].x-point[j].x;
				double y2=point[i].y-point[j].y;
				path[i][j]=path[j][i]=sqrt(x2*x2+y2*y2);  //双向性
			}

		/*Floyd Algorithm*/

		for(k=1;k<=n;k++)    //k点是第3点
			for(i=1;i<n;i++)    //主要针对由i到j的松弛,最终任意两点间的权值都会被分别松弛为最大跳的最小(但每个两点的最小不一定相同)
				for(j=i+1;j<=n;j++)
					if(path[i][k]<path[i][j] && path[k][j]<path[i][j])    //当边ik,kj的权值都小于ij时,则走i->k->j路线,否则走i->j路线
					// 关键 Floyd-Warshall思想 ,开始允许1中转,到1,2(因为1遍历完了已经把最短赋值给的新的,所以默认包括了旧点),最后到1,2,3.。。n
						if(path[i][k]<path[k][j])               //当走i->k->j路线时,选择max{ik,kj},只有选择最大跳才能保证连通
							//这条路径的求最大边
							path[i][j]=path[j][i]=path[k][j];
						else
							path[i][j]=path[j][i]=path[i][k];

		cout<<"Scenario #"<<cases++<<endl;
		printf("Frog Distance = %.3f

",path[1][2]);//在这里path[1][2]表示所有1到2点的路径的最长距离中的最短的那一个,算是Floyd算法的一个巧妙改动


	}
	return 0;
}


原文地址:https://www.cnblogs.com/mingrigongchang/p/6246252.html