BGP function

ID

1-1-1

Description

Verify the BGP basic function.

Topology

 

Step

  1. Set the test environment as topology figure;
  2. Port A/B and sw1 run bgp;
  3. Port A/B generate bgp route 100.1.1.0/24, 100.1.2.0/24 respectively;
  4. Generate traffic from 100.1.1.0/24 to 100.1.2.0/24, 100.1.2.0/24 to 100.1.1.0/24;

Script

Sw1:

interface 0/2

routing

ip address 192.168.1.4 255.255.255.0

exit

interface 0/4

routing

ip address 192.168.2.4 255.255.255.0

exit

router ospf

exit

ipv6 router ospf

exit

router bgp 100

bgp router-id 1.1.1.1

network 192.168.1.0 mask 255.255.255.0

network 192.168.2.0 mask 255.255.255.0

bgp log-neighbor-changes

template peer peer_name

exit

neighbor 192.168.1.3 remote-as 101

neighbor 192.168.2.3 remote-as 201

Expectation

  1. Sw1 can learn routers100.1.1.0/24 and 100.1.2.0/24;
  2. Traffic from 100.1.1.0/24 to 100.1.2.0/24, 100.1.2.0/24 to 100.1.1.0/24 can be transmitted successfully;

Result

 pass

原文地址:https://www.cnblogs.com/maisha/p/12911833.html