POJ 2352 Stars

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25850   Accepted: 11292

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0
题目大意:给出一些腥腥的横坐标和纵坐标,而且星星的纵坐标按非递减排列,如果纵坐标相等,则横坐标按递增排列,任意两颗星星不会重合。如果有n颗星星的横坐标比某颗星星小而且纵坐标不大于那颗星星(即有n颗星星位于那颗星星的左下角或者左边)则此星星的等级为n,等级为1至n-1的星星的数量。
解题方法:线段数或者树状数组。
树状数组:
#include <stdio.h>

#define MAXNUM 32010
int t[MAXNUM];
int level[MAXNUM];

int lowbit(int x)
{
    return x & - x;
}

void Plus(int pos, int x)
{
    while(pos < MAXNUM)
    {
        t[pos] += x;
        pos += lowbit(pos);
    }
}

int getsum(int pos)
{
    int sum = 0;
    while(pos > 0)
    {
        sum += t[pos];
        pos -= lowbit(pos);
    }
    return sum;
}

int main()
{
    int n;
    scanf("%d", &n);
    int x, y;
    for (int i = 0; i < n; i++)
    {
        scanf("%d%d", &x, &y);
        level[getsum(x + 1)]++ ;
        Plus(x + 1, 1);
    }
    for (int i = 0; i < n; i++)
    {
        printf("%d\n", level[i]);
    }
    return 0;
}

 线段树:

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

#define  MAX_VAL 32005

typedef struct 
{
    int left;
    int right;
    int nCount;
}Line;

Line Node[MAX_VAL * 3];
int sum[15005];

void Build(int left, int right, int index)
{
    
    Node[index].left = left;
    Node[index].right = right;
    Node[index].nCount = 0;
    if (left == right)
    {
        return;
    }
    int mid = (left + right) / 2;
    Build(left, mid, 2 * index);
    Build(mid + 1, right, 2 * index + 1);
}

void Add(int x, int index)
{
    Node[index].nCount++;
    if (Node[index].left == x && Node[index].right == x)
    {
        return;
    }
    int mid = (Node[index].left + Node[index].right) / 2;
    if (x <= mid)
    {
        Add(x, index * 2);
    }
    else
    {
        Add(x, index * 2 + 1);
    }
}

int Query(int left, int right, int index)
{
    int sum = 0;
    if (Node[index].left == left && Node[index].right == right)
    {
        return Node[index].nCount;
    }
    else
    {
        int mid = (Node[index].left + Node[index].right) / 2;
        if (left > mid)
        {
            sum += Query(left, right, index * 2 + 1);
        }
        else
        {
            if (right <= mid)
            {
                sum += Query(left, right, index * 2);
            }
            else
            {
                sum += Query(left, mid, index * 2) + Query(mid + 1, right, index * 2 + 1);
            }
        }
        return sum;
    }
}

int main()
{
    int x, y, n;
    while(scanf("%d", &n) != EOF)
    {
        Build(0, MAX_VAL, 1);
        memset(sum, 0, sizeof(sum));
        for (int i = 1; i <= n; i++)
        {
            scanf("%d%d", &x, &y);
            sum[Query(0, x, 1)]++;
            Add(x, 1);
        }
        for (int i = 0; i < n; i++)
        {
            printf("%d\n", sum[i]);
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lzmfywz/p/3112649.html