数学--数论--HDU1792A New Change Problem(GCD规律推导)

A New Change Problem

Problem Description
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.

Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.

Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.

Sample Input
2 3 3 4

Sample Output
1 1 5 3

import java.util.Scanner;


public class Main {
	public static void main(String[] args) {

		Scanner in = new Scanner(System.in);
		int a,b;
		while(in.hasNext())
		{
			a=in.nextInt();
			b=in.nextInt();
			 System.out.println(a*b-a-b+" "+(a-1)*(b-1)/2);
		}
		in.close();
	}

}
原文地址:https://www.cnblogs.com/lunatic-talent/p/12798499.html